Log4Shell – Warnstufe Rot: Schwachstelle führt zu extrem kritischer Bedrohungslage
Log4Shell – Warnstufe Rot: Schwachstelle führt zu extrem kritischer Bedrohungslage

Log4Shell – Warnstufe Rot: Schwachstelle führt zu extrem kritischer Bedrohungslage

Lesezeit: 2 Minuten

Die kritische Schwachstelle (Log4Shell) in der weit verbreiteten Java-Bibliothek Log4j führt nach Einschätzung des Bundesamts für Sicherheit in der Informationstechnik (BSI) zu einer extrem kritischen Bedrohungslage. Das BSI hat daher seine bestehende Cyber-Sicherheitswarnung auf die Warnstufe Rot hochgestuft. Ursächlich für diese Einschätzung ist die sehr weite Verbreitung des betroffenen Produkts und die damit verbundenen Auswirkungen auf unzählige weitere Produkte. Die Schwachstelle ist zudem trivial ausnutzbar, ein Proof-of-Concept ist öffentlich verfügbar. Eine erfolgreiche Ausnutzung der Schwachstelle ermöglicht eine vollständige Übernahme des betroffenen Systems. Dem BSI sind welt- und deutschlandweite Massen-Scans sowie versuchte Kompromittierungen bekannt. Auch erste erfolgreiche Kompromittierungen werden öffentlich gemeldet.

Das ganze Ausmaß der Bedrohungslage ist nach Einschätzung des BSI aktuell nicht abschließend feststellbar. Zwar gibt es für die betroffene Java-Bibliothek Log4j ein Sicherheits-Update, allerdings müssen alle Produkte, die Log4j verwenden, ebenfalls angepasst werden. Eine Java-Bibliothek ist ein Software-Modul, das zur Umsetzung einer bestimmten Funktionalität in weiteren Produkten verwendet wird. Es ist daher oftmals tief in der Architektur von Software-Produkten verankert. Welche Produkte verwundbar sind und für welche es bereits Updates gibt, ist derzeit nicht vollständig überschaubar und daher im Einzelfall zu prüfen. Es ist zu erwarten, dass in den nächsten Tagen weitere Produkte als verwundbar erkannt werden.

IT Security
IT Security

Das BSI empfiehlt insbesondere Unternehmen und Organisationen, die in der Cyber-Sicherheitswarnung skizzierten Abwehrmaßnahmen umzusetzen. Darüber hinaus sollten die Detektions- und Reaktionsfähigkeiten kurzfristig erhöht werden, um die eigenen Systeme angemessen überwachen zu können. Sobald Updates für einzelne Produkte verfügbar sind, sollten diese eingespielt werden. Darüber hinaus sollten alle Systeme auf eine Kompromittierung untersucht werden, die verwundbar waren.


Die Behörde verweist auf eine Liste auf der Programmierplattform Github, die ggf. betroffene Produkte aufzählt

https://gist.github.com/SwitHak/b66db3a06c2955a9cb71a8718970c592


Quelle: BSI

Weitere Links

Links

[LUN2021] – RCE 0-day exploit found in log4j, a popular Java logging package

https://www.lunasec.io/docs/blog/log4j-zero-day/

[TWI2021] – Twitter Beitrag Apache Log4j2 jndi Remote Code Execution (RCE)

https://twitter.com/P0rZ9/status/1468949890571337731
[GIT2021a] – Proof of Concept (PoC) zur CVE-2021-44228

https://github.com/tangxiaofeng7/apache-log4j-poc

[GIT2021b] – Skript zur Überprüfung auf Verwundbarkeit

https://gist.github.com/byt3bl33d3r/46661bc206d323e6770907d259e009b6

[GIT2021c] – Github release von Log4j

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

fünf + 18 =

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.